Simplify ulog_map Get rid of the caller parameter. The kproplog semantics (without -R) for mapping the ulog are simple and almost completely different from other users of the ulog, so implement them as a static helper in kproplog. With hierarchical iprop, kpropd will need the same semantics as FKCOMMAND and FKADMIND, which were already identical. Get rid of the db_args parameter, since ulog_map no longer opens the database after #7552. Remove an inoperative lseek() call when creating a new ulog file. Rename ulog_filesize to filesize and compute it from scratch each time we use it, for easier analysis. If kdb_hmagic is zero, init the ulog header but don't skip the rest of the function; it's possible that we need to expand the ulog file. Remove an unneeded conditional before calling extend_file_to for an existing ulog. https://github.com/krb5/krb5/commit/6a4a4b7b5e3265e4a811a9fd72c2534e6c5f5fd4 Author: Greg Hudson Commit: 6a4a4b7b5e3265e4a811a9fd72c2534e6c5f5fd4 Branch: master src/include/kdb_log.h | 10 +---- src/kadmin/dbutil/dump.c | 2 +- src/kadmin/dbutil/kdb5_create.c | 6 +- src/kadmin/dbutil/kdb5_util.c | 3 +- src/kadmin/server/ovsec_kadmd.c | 3 +- src/lib/kadm5/srv/server_init.c | 7 +-- src/lib/kdb/kdb_log.c | 95 ++++++-------------------------------- src/lib/kdb/t_ulog.c | 2 +- src/slave/kpropd.c | 2 +- src/slave/kproplog.c | 54 ++++++++++++++-------- 10 files changed, 61 insertions(+), 123 deletions(-)