Skip Menu |
 

Download (untitled) / with headers
text/plain 3.7KiB
From matthew_glogowski@us.ibm.com Wed Jan 16 13:56:17 2002
Received: from fort-point-station.mit.edu (FORT-POINT-STATION.MIT.EDU [18.7.7.76])
by rt-11.mit.edu (8.9.3/8.9.3) with ESMTP id NAA25464
for <bugs@RT-11.mit.edu>; Wed, 16 Jan 2002 13:56:17 -0500 (EST)
Received: from lotus2.lotus.com (lotus2.lotus.com [129.42.241.42])
by fort-point-station.mit.edu (8.9.2/8.9.2) with ESMTP id NAA03913
for <krb5-bugs@mit.edu>; Wed, 16 Jan 2002 13:56:16 -0500 (EST)
Received: from internet2.lotus.com (internet2 [172.16.131.236])
by lotus2.lotus.com (8.12.1/8.12.1) with ESMTP id g0GIviTQ007146
for <krb5-bugs@mit.edu>; Wed, 16 Jan 2002 13:57:44 -0500 (EST)
Received: from a3mail.lotus.com (a3mail.lotus.com [9.95.5.66])
by internet2.lotus.com (8.12.1/8.12.1) with ESMTP id g0GIuFS0010977
for <krb5-bugs@mit.edu>; Wed, 16 Jan 2002 13:56:15 -0500 (EST)
Message-Id: <OF1A0A5748.0091E888-ON85256B43.006645CF@lotus.com>
Date: Wed, 16 Jan 2002 13:47:28 -0500
From: "Matthew Glogowski/Cambridge/IBM" <matthew_glogowski@us.ibm.com>
To: krb5-bugs@mit.edu
Subject: login name too long errors

Show quoted text
>Number: 1045
>Category: pending
>Synopsis: login name too long errors
>Confidential: yes
>Severity: serious
>Priority: medium
>Responsible: gnats-admin
>State: closed
>Class: sw-bug
>Submitter-Id: unknown
>Arrival-Date: Wed Jan 16 13:57:00 EST 2002
>Last-Modified: Thu Apr 4 16:41:11 EST 2002
>Originator: Matthew Glogowski
>Organization:
IBM Software Group
Show quoted text
>Release: krb5-1.2.3
>Environment:

System: SunOS crabgrass 5.8 Generic_108528-12 sun4u sparc
SUNW,Ultra-2
Architecture: sun4

Show quoted text
>Description:
there appears to be a problem with the kerberos 1.2.3 sources.
i compiled the code with:

./configure --prefix=/usr/kerberos --enable-shared
--with-tcl=/usr/local --with-krb4

make all ran fine. reported no errors or warnings.

in the /etc/inetd.conf file on my system i have telnet and
krb5_prop
enabled for synchronization.

# Kerberos Services
telnet stream tcp nowait root /usr/kerberos/sbin/telnetd \
telnetd -a valid
krb5_prop stream tcp nowait root /usr/kerberos/sbin/kpropd kpropd

Show quoted text
>How-To-Repeat:

here is the series of commands i issued to attempt login:

matthewg@crabgrass [matthewg]% /usr/kerberos/bin/kinit
Password for matthewg@LOTUS.COM:
matthewg@crabgrass [matthewg]% /usr/kerberos/bin/klist
Ticket cache: FILE:/tmp/krb5cc_12790
Default principal: matthewg@LOTUS.COM

Valid starting Expires Service principal
01/16/02 13:17:35 01/16/02 23:17:35 krbtgt/LOTUS.COM@LOTUS.COM

Kerberos 4 ticket cache: /tmp/tkt12790
klist: You have no tickets cached

Trying 9.95.18.57...
Connected to crabgrass.lotus.com (9.95.18.57).
Escape character is '^]'.
Waiting for encryption to be negotiated...
[ Kerberos V5 accepts you as ``matthewg@LOTUS.COM'' ]
done.
login name 'matthewg' too long
login:

if i perform the same commands for the root account, i do get
access
without any problems. i also tried to get system access with
krlogin,
and the same error appears with 'login name too long'.

i have not tested the username character limit.

when i was using krb-1.2.2 sources from MIT there were no
problems with ktelnet username length.

Show quoted text
>Fix:

Show quoted text
>Audit-Trail:

State-Changed-From-To: open-closed
State-Changed-By: hartmans
State-Changed-When: Thu Apr 4 16:40:23 2002
State-Changed-Why:
Fixed in 1.2.4.

Show quoted text
>Unformatted:
net
Matthew Glogowski
no
login name too long errors with remote access
serious
medium
krb-1.2.3
sw-bug
krb5-1.2.3