Skip Menu |

Download (untitled) / with headers
text/plain 3.9KiB
From Tue Apr 23 00:32:47 2002
by (8.9.3/8.9.3) with ESMTP id AAA26009
for <>; Tue, 23 Apr 2002 00:32:46 -0400 (EDT)
Received: from ( [])
by (8.9.2/8.9.2) with ESMTP id AAA27580
for <krb5-bugs@MIT.EDU>; Tue, 23 Apr 2002 00:32:45 -0400 (EDT)
Received: from mail pickup service by with Microsoft SMTPSVC;
Mon, 22 Apr 2002 21:32:45 -0700
Received: from by with HTTP;
Tue, 23 Apr 2002 04:32:44 GMT
Message-Id: <>
Date: Tue, 23 Apr 2002 04:32:44 +0000
From: "Edgar Lovecraft" <>
To: krb5-bugs@MIT.EDU
Subject: Cannot find KDC problems

Show quoted text
>Number: 1094
>Category: pending
>Synopsis: Cannot find KDC problems
>Confidential: yes
>Severity: serious
>Priority: medium
>Responsible: gnats-admin
>State: open
>Class: sw-bug
>Submitter-Id: unknown
>Arrival-Date: Tue Apr 23 00:33:00 EDT 2002
<html><div style='background-color:'><P>I ran across this listing when I was having some troubles getting kadmin and kinit to find the KDC for my realm in a new KerberosV install on RedHat 7.2 on an isolated network.&nbsp; What I eventually traced it down to was this.&nbsp; The defined host name for the local machine was (/etc/sysconfig/network, same for the /etchosts file ( kerberos), of course this is also what dns was pointing to krbmaster A, kerberos CNAME krbmaster, _kerberos._upd SRV 0 0 88 krbmaster, etc.)&nbsp; Once I changed the host name on the local machine from kerberos to krbmaster (in /etc/sysconfig/network and /etc/hosts), everything worked just fine.&nbsp; Just thought that I would let you know as I could not find anything on this out there on the web, this was the closest find I had.&nbsp; Mabey I missed something in the DOCS, but I do not remember reading anything this !
potential conflict.</P>
<P>Cannot find KDC</P>
<P>daemon@ATHENA.MIT.EDU (Nov-William H Rahe)<BR>Wed Jul 31 10:23:41 1991</P>
<P>Date: Wed, 31 Jul 91 07:59:40 MDT
From: <A href=""></A> (Nov-William H Rahe)
To: <A href="mailto:krb5-bugs@MIT.EDU">krb5-bugs@MIT.EDU</A>
I have successfully? built V5 on a Sun 4/110. I created the database
(/krb5/ Used kdb5_stash to preserve the key. Created
two principals whrahe using kdb5_edit av4k facility and whrahev5 using
kdb5_edit ank facility. Started krb5kdc in background (not in inetd)
Using old V4 kinit I obtain tickets for whrahe. Using V5 kinit with
whrahev5, I get:
kinit: Cannot find KDC for requested realm while getting initial
credentials. What piece of the puzzle am I missing? .
You should make sure that you have created krb.conf and krb.realms files
in /krb5. If that didn't fix the problem, you may have discovered a
more deep-seated problem with Kerberos V5 on Suns. I've gotten a
similar report from someone else who said that his krb.conf and
krb.realms were correctly set up but who still had problems. I don't
know what explicitly causing the problem or a fix yet, however. If you
can find more information, I would appreciate it if you could send it to
krb5-bugs@MIT.EDU. - Ted
I also have correct krb.conf and krb.realms. I will begin to see if I
can isolate what realm krb5_locate_kdc is passing to sendto_kdc.</P></div><br clear=all><hr>Send and receive Hotmail on your mobile device: <a href=''>Click Here</a><br></html>
Subject: Cannot find KDC problems
Looks like a misconfigured client system.