Skip Menu |

To: krb5-bugs@MIT.EDU
Subject: rcp tests and ipv6
From: Ken Raeburn <raeburn@MIT.EDU>
Date: Thu, 19 Dec 2002 18:20:57 -0500

The test suite support for rcp doesn't handle ipv6, nor does it handle
output from rcp saying that connections were refused at the first
address tried but there are other addresses to try.

If the local hostname maps to an ipv6 address as well as an ipv4
address, this combination can cause false negative results from the
test suite.

I suggest fixing both:

- make the standalone daemon code handle ipv6 if available

- make the test suite deal with multiple listed addresses when some
are refusing connections, timing out, whatever (this one might also
affect, say, disconnected laptops with their "normal" addresses
listed in /etc/hosts but not on any interface while disconnected)
Download (untitled)
message/rfc822 4.9KiB
Return-Path: <krbsnap@MIT.EDU>
Received: from by (8.9.2/4.7) id
FAA18748; Thu, 19 Dec 2002 05:34:09 -0500 (EST)
From: <krbsnap@MIT.EDU>
Received: from (DCL.MIT.EDU [])
by (8.9.2/8.9.2) with ESMTP id FAA04220
for <>; Thu, 19 Dec 2002 05:34:08 -0500 (EST)
Received: (from krbsnap@localhost) by (8.9.3)
id FAA25216; Thu, 19 Dec 2002 05:34:08 -0500 (EST)
Date: Thu, 19 Dec 2002 05:34:08 -0500 (EST)
Message-Id: <>
Subject: krb5 snapshot build dcl 32-bit gcc
Apparently-To: <krbdev-auto@MIT.EDU>
Lines: 87
Xref: all-in-one all.2002-12:2595
MIME-Version: 1.0

is bash
To grab logs, run:
perl /mit/krbdev/testing/grab-logs dcl /var/krbsnap/autobuild-static dcl-sparc32-gcc-static

echo is bsd type
Starting build on dcl at Thu Dec 19 04:10:01 EST 2002.
Config options --disable-shared --enable-static CC=gcc --with-tcl=/mit/krbdev/arch/sun4x_58.
cc is /usr/athena/bin/cc
gcc is /usr/gcc/bin/gcc
as is /usr/ccs/bin/as
ld is /usr/ccs/bin/ld
ranlib is /usr/ccs/bin/ranlib
echo is a shell builtin
Make program is specified as make.
Working in /var/krbsnap/autobuild-static/work-20021219.0410.
Download...04:10:05 URL: [6790012] -> "krb5-current.tar.gz" [1]
unpack...Version: HEAD current-20021219 20021219!)...check...
error running krb5 tests
output in /var/krbsnap/autobuild-static/work-20021219.0410/check-log
Show quoted text
Running ./krb-root/telnet.exp ...
NOTE: telnet test requires ability to rlogin as root
Running ./krb-standalone/gssapi.exp ...
Running ./krb-standalone/gssftp.exp ...
Running ./krb-standalone/kadmin.exp ...
Running ./krb-standalone/rcp.exp ...
FAIL: rcp from
FAIL: rcp to
FAIL: encrypted rcp from
FAIL: encrypted rcp to
Running ./krb-standalone/rsh.exp ...
Running ./krb-standalone/sample.exp ...
Running ./krb-standalone/standalone.exp ...
Running ./krb-standalone/v4gssftp.exp ...
Running ./krb-standalone/v4krb524d.exp ...
Running ./krb-standalone/v4standalone.exp ...

=== krb Summary ===

# of expected passes 1145
# of unexpected failures 32
# of unsupported tests 16
*** Error code 1
make: Fatal error: Command failed for target `check-runtest-yes'
Current working directory /var/krbsnap/autobuild-static/work-20021219.0410/krb5-current/src/tests/dejagnu
*** Error code 1
make: Fatal error: Command failed for target `check-recurse'
Current working directory /var/krbsnap/autobuild-static/work-20021219.0410/krb5-current/src/tests
*** Error code 1
make: Fatal error: Command failed for target `check-recurse'

Rechecking attached filesystems:

filesystem mountpoint user mode
---------- ---------- ---- ----
dev-sun4sys-91 - root -,nosuid
dev-sun4-srvd-91 /srvd root n,nosuid
dev-sun4-os-91 /os root n,nosuid
dev-sun4-inst-91 /install root n,nosuid
raeburn /mit/raeburn raeburn w,nosuid
acro /mit/acro raeburn w,nosuid
watchmaker /mit/watchmaker raeburn n,nosuid
aui /mit/aui raeburn w,nosuid
discuss /mit/discuss raeburn w,nosuid
consult /mit/consult raeburn n,nosuid
zephyr /mit/zephyr raeburn w,nosuid
graphics /mit/graphics raeburn n,nosuid
sipb /mit/sipb raeburn n,nosuid
outland /mit/outland raeburn n,nosuid
emacs /mit/emacs raeburn n,nosuid
zlogs /mit/zlogs raeburn n,nosuid
internet-drafts /mit/internet-drafts raeburn n,nosuid
rfc /mit/rfc raeburn n,nosuid
eichin /mit/eichin raeburn w,nosuid
sipbzlog /mit/sipbzlog raeburn n,nosuid
zlog /mit/zlog raeburn n,nosuid
krb5 /mit/krb5 raeburn w,nosuid
sunsoft_v6.1a /mit/sunsoft_v6.1a raeburn w,nosuid
sunsoft /mit/sunsoft raeburn w,nosuid
krbdev /mit/krbdev {raeburn,krbsnap} w,nosuid
gnu /mit/gnu {raeburn,krbsnap} n,nosuid
infoagents /mit/infoagents {raeburn,root} w,nosuid
I think the IPv6 problem should now be solved; I've just checked in
changes to make the rsh server accept connections by IPv6 as well as
IPv4, and the test suite passes those tests on dcl.

The test suite should still be modified to handle the error that used to
be reported, as long as the copy still succeeds.
Subject: rcp test server and ipv6
Created ticket 1291 for test suite issue, close out this one with the
fix to the test server code.