Skip Menu |

Download (untitled) / with headers
text/plain 3.2KiB
From tlyu@MIT.EDU Tue Nov 12 16:02:54 1996
Received: from MIT.EDU (SOUTH-STATION-ANNEX.MIT.EDU []) by rt-11.MIT.EDU (8.7.5/8.7.3) with SMTP id QAA28138 for <bugs@RT-11.MIT.EDU>; Tue, 12 Nov 1996 16:02:53 -0500
Received: from TESLA-COIL.MIT.EDU by MIT.EDU with SMTP
id AA21857; Tue, 12 Nov 96 16:02:48 EST
Received: by tesla-coil.MIT.EDU (5.x/4.7) id AA16878; Tue, 12 Nov 1996 16:02:21 -0500
Message-Id: <9611122102.AA16878@tesla-coil.MIT.EDU>
Date: Tue, 12 Nov 1996 16:02:21 -0500
From: tlyu@MIT.EDU
Reply-To: tlyu@MIT.EDU
To: krb5-bugs@MIT.EDU
Subject: rsh host fails
X-Send-Pr-Version: 3.99

Show quoted text
>Number: 179
>Category: krb5-appl
>Synopsis: rsh host fails
>Confidential: no
>Severity: serious
>Priority: medium
>Responsible: krb5-unassigned
>State: closed
>Class: sw-bug
>Submitter-Id: unknown
>Arrival-Date: Tue Nov 12 16:03:01 EST 1996
>Last-Modified: Thu Sep 13 22:07:23 EDT 2001
>Originator: Paul Pomes <>
Show quoted text
>Release: 1.0-development

System: SunOS tesla-coil 5.4 Generic_101945-37 sun4m sparc

Show quoted text
[2228] daemon@ATHENA.MIT.EDU (Paul Pomes) Kerberos-V5-bugs 09/16/96 11:31 (37 lines)
Subject: rsh host fails
To: krb5-bugs@MIT.EDU
From: Paul Pomes <>
Date: Mon, 16 Sep 1996 08:30:55 -0700


% rsh somehost
rsh: kcmd to host nala failed - No credentials cache file found
trying normal rlogin (/bin/rlogin)
usage: rlogin [ -E | -ex ] [ -l username ] [ -8 ] [ -L ] host

To fix, add rsh as a secondary test string to bsd/krlogin.c

RCS file: RCS/krlogin.c,v
retrieving revision 1.1
diff -c -r1.1 krlogin.c
*** krlogin.c 1996/09/16 15:22:32 1.1
--- krlogin.c 1996/09/16 15:23:34
*** 1580,1586 ****
host = argv[0];
! if (!strcmp(host, "rlogin"))

execv(UCB_RLOGIN, argv);
--- 1580,1586 ----
host = argv[0];
! if (!strcmp(host, "rlogin") || !strcmp(host, "rsh"))

execv(UCB_RLOGIN, argv);

Show quoted text

Show quoted text

Show quoted text

From: "Barry Jaspan" <bjaspan@MIT.EDU>
To: tlyu@MIT.EDU
Cc: krb5-bugs@MIT.EDU
Subject: Re: krb5-appl/179: rsh host fails
Date: Wed, 13 Nov 1996 20:48:16 GMT

I believe that the rsh fallback to rlogin is an historical mistake
that we do not need to propagate any further. Therefore, I propose
fixing this mistake by removing the fallback, rather than by making it
work in one more situation (there certainly being other situations in
which it will still fail).

Incidentally, I believe the krlogin -> ucb rlogin fallback is also a
mistake that should be removed. A site that really wants it (I doubt
any do) can implement it better with a very short shell script.

Both of these changes would be in line with Sam's recent change of
removing rhosts support from klogind, which was also a mistake from
beginning and besides that never worked at all.

State-Changed-From-To: open-closed
State-Changed-By: raeburn
State-Changed-When: Thu Sep 13 22:06:13 2001

Added check, but use rlogin pathname as argv[0] in that case. Some
systems' rlogin will not accept the hostname as argv[0].

Show quoted text