Skip Menu |
 

Download (untitled) / with headers
text/plain 3.4KiB
From dchan@cisco.com Tue Dec 17 20:29:27 1996
Received: from MIT.EDU (SOUTH-STATION-ANNEX.MIT.EDU [18.72.1.2]) by rt-11.MIT.EDU (8.7.5/8.7.3) with SMTP id UAA24198 for <bugs@RT-11.MIT.EDU>; Tue, 17 Dec 1996 20:29:26 -0500
Received: from greatdane.cisco.com by MIT.EDU with SMTP
id AA28388; Tue, 17 Dec 96 20:29:25 EST
Received: (dchan@localhost) by greatdane.cisco.com (8.6.12/8.6.5) id RAA08994; Tue, 17 Dec 1996 17:29:24 -0800
Message-Id: <199612180129.RAA08994@greatdane.cisco.com>
Date: Tue, 17 Dec 1996 17:29:24 -0800 (PST)
From: Derek Chan <dchan@cisco.com>
To: krb5-bugs@MIT.EDU
Cc: dchan@cisco.com (Derek Chan)
Subject: problems in compiling beta 7 kerberos

Show quoted text
>Number: 300
>Category: krb5-build
>Synopsis: problems in compiling beta 7 kerberos
>Confidential: no
>Severity: serious
>Priority: low
>Responsible: krb5-unassigned
>State: closed
>Class: sw-bug
>Submitter-Id: unknown
>Arrival-Date: Tue Dec 17 20:30:01 EST 1996
>Last-Modified: Thu Feb 05 17:45:21 EST 1998
>Originator:
>Organization:
>Release:
>Environment:
>Description:
Hi,

After running "./configure --with-cc=gcc" and "make". I run into a problem
where make seems to use conflicting include files from different places. There
are many warnings of macro being redefined and then finally it ends like this:

In file included from ../btree/bt_get.c:44:^M
/usr/local/lib/gcc-include/stddef.h:6: conflicting types for `ptrdiff_t'^M
/usr/include/sys/stdtypes.h:28: previous declaration of `ptrdiff_t'^M
/usr/local/lib/gcc-include/stddef.h:12: conflicting types for `size_t'^M
/usr/include/sys/stdtypes.h:27: previous declaration of `size_t'^M
make[3]: *** [bt_get.o] Error 1^M
make[3]: Leaving directory `/rub/mitkrb/krb5-beta7/src/util/db2/obj'^M
make[2]: *** [all] Error 1^M
make[2]: Leaving directory `/rub/mitkrb/krb5-beta7/src/util/db2'^M
make[1]: *** [all-unix] Error 1^M
make[1]: Leaving directory `/rub/mitkrb/krb5-beta7/src/util'^M
make: *** [all-unix] Error 1^M
autons-prod-coreasun:/rub/mitkrb/krb5-beta7/src 2 >

I can provide a full log if needed. Any idea why this happened and how to
fix it.

Thanks in advance

Derek

Show quoted text
>How-To-Repeat:
>Fix:
>Audit-Trail:

From: "Theodore Y. Ts'o" <tytso@MIT.EDU>
To: krb5-bugs@MIT.EDU, Derek Chan <dchan@cisco.com>
Cc: gnats-admin@RT-11.MIT.EDU, krb5-prs@RT-11.MIT.EDU
Subject: Re: pending/300: problems in compiling beta 7 kerberos
Date: Wed, 18 Dec 1996 13:51:49 -0500

Derek,
You didn't state which platform you were having these problem
with. This is critical, since the type/compilation problems you stated
are extremely OS, and sometimes compiler, dependent. Could you please
let us know what platform, Operating System, OS version, and compiler
version you tried to use?

Also, we will be releasing the 1.0 release of Kerberos in the
very near future, which will work on a much wider range of platforms
than the Beta 7 release. So using the 1.0 release when it becomes
available later this week may be your best bet.

- Ted

State-Changed-From-To: open-feedback
State-Changed-By: tlyu
State-Changed-When: Sun Mar 16 01:59:47 1997
State-Changed-Why:

Refiled

Responsible-Changed-From-To: gnats-admin->krb5-unassigned
Responsible-Changed-By: tlyu
Responsible-Changed-When: Sun Mar 16 02:00:37 1997
Responsible-Changed-Why:

State-Changed-From-To: feedback-closed
State-Changed-By: tlyu
State-Changed-When: Thu Feb 5 17:45:07 1998
State-Changed-Why:

Stale


Show quoted text
>Unformatted: