Skip Menu |
 

Subject: kadm5_hook does not have rename method
Functional rename support (#6323) was added to kadmin shortly after the
kadm5_hook interface (#6791). We should have added a rename method to
kadm5_hook at that time, but neglected to do so.
From: ghudson@mit.edu
Subject: git commit

Add rename method to kadm5_hook

Bump the minor version of the kadm5_hook interface to 2 and add a
rename method. Invoke the rename method in kadm5_rename_principal()
like we do for other libkadm5srv operations.

Partly based on a patch from John Hascall.

https://github.com/krb5/krb5/commit/a99e5565e99b83a86002332e39938aa6bed6a26a
Author: Greg Hudson <ghudson@mit.edu>
Commit: a99e5565e99b83a86002332e39938aa6bed6a26a
Branch: master
doc/plugindev/kadm5_hook.rst | 5 +++--
src/include/krb5/kadm5_hook_plugin.h | 11 +++++++++++
src/lib/kadm5/server_internal.h | 7 +++++++
src/lib/kadm5/srv/kadm5_hook.c | 10 +++++++++-
src/lib/kadm5/srv/svr_principal.c | 8 ++++++++
src/plugins/kadm5_hook/test/main.c | 8 ++++++++
src/tests/t_kadm5_hook.py | 4 ++++
7 files changed, 50 insertions(+), 3 deletions(-)