Skip Menu |
 

From: Leigh Fonseca <leigh.fonseca@macys.com>
To: "kfw-bugs@MIT.EDU" <kfw-bugs@mit.edu>
Subject: MIT Kerberos Ticket Manager will no longer load in windows 10
Date: Mon, 19 Jun 2017 18:02:11 +0000
Download pastedImage.png
image/png 25.1KiB
pastedImage.png
Download pastedImage.png
image/png 22KiB
pastedImage.png

Greetings,


I have been using the MIT Kerberos Ticket Manager for a couple of months now and last Thursday, the application stopped loading when I launched it (double-click app icon on the Desktop).  

  • It is listed in my Task Manager > Startup, but not present in the system tray.  
  • If I run klist from the command line I get a logonId with 0 Cached Tickets.  
  • If I try to kinit, it says it's initializing the Kerberos 5 library.
  • I did not make any changes to my krb5.ini file and have uninstalled/reinstalled/replaced krb5.ini file with the recommended file from IT.  

Have you see anything like this before and can you help?  I'm blocked from accessing our environment.  Are there any settings I can verify/update?






Thanks,
Leigh





Leigh Fonseca
Data Strategy & Visualization | Macy's, Inc.
680 Folsom St, 14th Fl | San Francisco, CA 94107
Mobile: (415) 405-2120 | Email: leigh.fonseca@macys.com

Date: Tue, 20 Jun 2017 22:37:02 -0500
From: Benjamin Kaduk <kaduk@mit.edu>
To: Leigh Fonseca <leigh.fonseca@macys.com>
Subject: Re: MIT Kerberos Ticket Manager will no longer load in windows 10
CC: "kfw-bugs@MIT.EDU" <kfw-bugs@mit.edu>
Download (untitled) / with headers
text/plain 1.7KiB
On Mon, Jun 19, 2017 at 06:02:11PM +0000, Leigh Fonseca wrote:
Show quoted text
> Greetings,
>
>
> I have been using the MIT Kerberos Ticket Manager for a couple of months now and last Thursday, the application stopped loading when I launched it (double-click app icon on the Desktop).
>
> * It is listed in my Task Manager > Startup, but not present in the system tray.
> * If I run klist from the command line I get a logonId with 0 Cached Tickets.
> * If I try to kinit, it says it's initializing the Kerberos 5 library.
> * I did not make any changes to my krb5.ini file and have uninstalled/reinstalled/replaced krb5.ini file with the recommended file from IT.
>
> Have you see anything like this before and can you help? I'm blocked from accessing our environment. Are there any settings I can verify/update?

I don't think we've seen any similar reports, no.

The klist from the command line is probably one provided by windows;
you would need to be running things with an absolute path to be sure
to use the KfW copies (e.g., C:\Program
Files\MIT\Kerberos\bin\klist.exe)

The full output from running kinit (with the full path) might be
interesting to see (e.g., does it hang after "initializing the
Kerberos 5 library", or give a password prompt, or go back to the
cmd.exe prompt)?

It's also possible that stopping any MIT Kerberos.exe from the task
manager and then running MIT Kerberos.exe manually from the
command line would give a helpful error message, but I don't think
there are actually many cases where there would be a useful message.

Do you know if there were any windows updates that roughly
correspond to your observed behavior change? (Updates can be
installed silently in some configurations, as I understand it.)

-Ben