Skip Menu |

Download (untitled) / with headers
text/plain 4.1KiB
From Tue Oct 3 02:10:09 2000
by (8.9.3/8.9.3) with SMTP id CAA21096
for <bugs@RT-11.MIT.EDU>; Tue, 3 Oct 2000 02:10:00 -0400 (EDT)
Received: from by MIT.EDU with SMTP
id AA08910; Tue, 3 Oct 00 02:09:56 EDT
Received: from ( [])
by (8.8.7/8.8.7) with ESMTP id XAA28789
for <>; Mon, 2 Oct 2000 23:09:56 -0700
Message-Id: <>
Date: Tue, 03 Oct 2000 00:08:19 -0600
From: Chris Rasch <>
To: krb5-bugs@MIT.EDU
Subject: Bug in the Kerberos ftp client on Red Hat 6.2?

Show quoted text
>Number: 894
>Category: krb5-appl
>Synopsis: Bug in the Kerberos ftp client on Red Hat 6.2?
>Confidential: no
>Severity: serious
>Priority: medium
>Responsible: krb5-unassigned
>State: open
>Class: sw-bug
>Submitter-Id: unknown
>Arrival-Date: Tue Oct 3 02:11:00 EDT 2000
>Last-Modified: Thu Jul 5 20:55:05 EDT 2001
>Originator: Chris Rasch <>

I apologize if this is the inappropriate place to send this bug
report--this seemed to be the most appropriate list, based on what I
could find on the web. If it isn't appropriate, please let me know.

Show quoted text
-----------Begin Bug Report---------------------------------------

There appears to be a problem with the Kerberos ftp client
auto-authentication routines. Here's a history of the problem I've

I just installed Xemacs-21.1.11
(Carlsbad Caverns) on a new installation of Red Hat 6.2. I also
downloaded and
untarred the
xemacs-sumo-2000-09-04.tar.gz into the /usr/local/lib/xemacs/
directory. When I
to "Update Installed Packages" (from any of the U.S. mirrors), I got the

following error messages:

Open Metalab.Unc.Edu
Connected To Metalab.Unc.Edu.
220 Helios.Oit.Unc.Edu Ftp Server (Version Wu-2.6.1(1) Sat Jul 8
10:18:10 Edt 2000) Ready.
Quote User "Anonymous"
530 Please Login With User And Pass.

If I tried to open an ftp connection to / I get:

Opening FTP connection to
Logging in as user anonymous...
FTP error: USER request failed: 500 AUTH not understood

Judging from the error codes, the problem is with the ftp client.
Output from ps
-Afl, during an attempt to login to from within Xemacs
indicates that
Xemacs is using /usr/kerberos/bin/ftp as the ftp client:

000 S root 12825 12715 3 73 0 - 562 read_c 03:45 ttyp2
/usr/kerberos/bin/ftp -i -n -g -v

When I tried to manually try to log in to the ftp server using the
command line above:

# /usr/kerberos/bin/ftp -i -n -g -v

I got the following error codes:

Connected to
220 ProFTPD 1.2.0pre10 Server (ProFTPD on []
500 AUTH not understood.
500 AUTH not understood.
KERBEROS_V4 rejected as an authentication type

Therefore, there appears to be a problem with the Kerberos ftp client
auto-authentication routines.

The workaround is to specify another ftp client (e.g. /usr/bin/ftp) as
Sperber <> suggested,

> Alternatively, use a
> non-kerberized ftp client (in our setup, /usr/bin/ftp is it) and set
> the value of `efs-ftp-program-name' to it.

...or disable auto-authentication, as Evgeny Roubinchtein

> I saw the same exact problem. Add a "-u" to the list which is the
> value of the efs-ftp-program-args variable (either using the Customize

> facility (i.e. "M-x customize-variable efs-ftp-program-args")
> the cleanest),


> (eval-after-load "efs"
> '(setq efs-ftp-program-args (cons "-u" efs-ftp-program-args)))

-------------------End Bug


Responsible-Changed-From-To: gnats-admin->krb5-unassigned
Responsible-Changed-By: raeburn
Responsible-Changed-When: Thu Jul 5 20:54:51 2001